Will the old sim card be disconnected before the new sim card activated?

Andrew2008
Conductor
2 Replies 1222 Views

I would like to share this topic as I got this situation which make me so frustrating, not sure if there is an error from AGL, any other customer got the same issue?

 

I transferred my existing 2 sim cards from TPG to AGL on 30th Sep (one is e-sim card, another one is physical sim card). However, old sim card disconnected before new sim card activated and caused me no phone numbers to be used.

 

So, for the e-sim card, on the same day I received the welcome email with the qr-code for asking me to start for activation with the guide. I have followed the instruction and scanned the qr-code and installed the e-sim card to my iPhone, but shows "no service". Days later, I contacted with AGL customer service, then, they issued me 2nd qr-code and ask me to active. However, when doing the same thing, it shows "Unable to active this e-sim card, pls contact your service provider", then, I spent a lot of time on seeking help with AGL customer service...  For the physical sim card, I did not receive it after days, after checked with customer service, then, I got the AUPOST email notice and waiting for delivery.

 

However, until yesterday, which is 5 days later. I realized my both old sim card number not working anymore, it shows "no service", but my new sim cards, one is not activated successfully, and another one still on the way, how they can disconnect my old sim card? I am unable to use my phone from yesterday to today, I contacted with AGL customer service via Chat / Message / Call channel, was asked for providing driving license, and passport to verify my account. So far, my issue still not solved after speaking with couple of agent.

 

So, I would like to know if this is normal or where is wrong? This is already 5 days, not sure if today it can be fixed before the weekend. Any suggestion? if I can login to AGL my account and request a new e-sim card?

2 REPLIES 2
Andrew2008
Conductor
0 Replies 1209 Views

On Saturday, I callected my parcel from AU POST, you know the staff could 't find the pacel, actually it is just a Physical Sim card in a letter. After home, I insearted this sim card to my iphone, it was working and was able to make phone call. It is not easy after the service disconnected few days without phone calls & messages.

 

Today (Monday), I called  AGL customer serivice again for solving my e-sim card, but not sure what is the reason why I am unable to active my e-sim card. So, I requested the e-sim replacement andsent me a new qr code for me to active, now this one works and I have installed into my phone, but just shows "NO SERVICE", which is exactly same with the 1st qr code I have tried, just "no service" or sometimes shows "SOS only". The guide asks me to login my AGL online account to active it, however, there is no active button there, and it has already started to charge me from 5th Oct.

 

So, I really don't know, as I have spent over one week on this matter and tmr I will keep calling AGL to see how to fix it for the last time call, otherwise, I am planning to transfer this number back to TPG if still.

 

Please help me if you can... 

Thx

 

2.png1.png

Andrew2008
Conductor
0 Replies 1200 Views

Finally, Today, my e-sim card issue solved completely. Just would like to Thanks to John (From AGL customer Service Team) helped me through out, and explained me the all process, and status from AGL end. Finally get this solved.

 

Generally, the e-sim activation process did not finish from AGL end, it is impossible to get your e-sim online.

The below information I shared are the reasons and may be useful for other customers who have the similar issue and struggling on it.

  • On 09 Oct, I requested the e-sim card replacement due to the 1st & 2nd qr code not working in the past week, no once helped me for the reason.
  • I received the email with qr code from AGL after couple of hours. Then, I scanned installed it later afternoon on the same day, but it shows the same issue that happened same with the 1st qr code, just shows "No service" or "SOS only"
  • Contacted AGL customer service, today it is quick not so long waiting, and John helped me to have checked the status from his end, shows "waiting" from AGL system. Then, John helped to trigger it, the status immediately changed to "Accepted", this step will be waiting around 1-2 hours. In the meantime I was keeping staying connection with John, roughly around one hour, John said the status changed to "Processing", and ask me to try again...  Finally, it connected and has the signal. The status of my e-sim card from AGL end shows "completed"
  • I tested and it is working.

It is not easy for transferring my 2 numbers to AGL, cost me too much. But the very lucy thing is that AGL customer service system assigned John to me and help me for this eventually, otherwise, I am still waiting or I have already gave up.

 

Thanks John again, much appreciated, sorry I did not have John's full name.