Web Site - Electricity Usage

Michael4
Conductor
1 Reply 963 Views

Love the AGL website and the electricity usage drill downs. However has there been a recent software change that has caused the account period to be stuck to the last period and the end date extended every day? Otherwise have I changed the profile or parameters somehow? 

 

 

 

 

4 REPLIES 4
David_AGL
AGL Community Manager
1 Reply 942 Views

Hi @Michael4 , there hasn't been any ipdate as far as I'm aware - are you still seeing this issue?

Michael4
Conductor
1 Reply 940 Views

Yes, the issue is still present. I suspect the issue is a latent bug related to billing payments and reconciliation and would occur on rare instances, hard to test for all conditions.

 

The issue appeared after the payment was transacted between IMB bank and AGL. I used the AGL Web  App payment option to pay the amount shown (around 14/10.2023). The response was will take at least 2 days to clear, it was cleared on the 18/10/2023 and the balance showed zero dollars. After that, the billing cycle is wrong and no usage data is being uploaded. Talking with a customer service representative 2 days ago he said 2 dollars was pending and is due at the end of this billing cycle. I said that is odd as I paid the full amount as shown and the system says paid an the bank statements show the exact amount being transferred. Here I think is the latent problem (bug).

 

The system assumes I have a late payment (which I don't, I paid 1.5 week in advance and paid the full amount), however it has 2 dollars owing (monies) and a conditional in the code is checking for this or using this to incorrectly adjust the billing cycle and stopping the upload of usage data. Assumption only and does not rely on code updates but is a latent bug which is difficult to check for.

David_AGL
AGL Community Manager
1 Reply 916 Views

@Michael4 if you'd like me to escalate this as a possible issue, please shoot me through a private message (click my name) and let me know your account number and a screenshot illustrating the issue if possible.

Michael4
Conductor
0 Replies 914 Views

Hi David,

Thank you for getting back.

The issue was resolved on 28.10.2023, I sent confirmation of this to the AGL service desk. So can mark the incident as successfully resolved.

Happy with the effort and result.