HORRIBLE EXPERIENCE WITH AGL NBN BUNDLE!

jacjacp
Switched-on
1 Reply 860 Views

Told us the internet is connected on the 2nd of OCT.

 

It is now the 11th of OCT still have nothing!

 

Called in today to cancel the plan (within 10-day cooldown period), the customer service told us we have to pay the first month's bill since on their end it is clearly connected???????????? HELLO!???????? We haven't even start using AGL's internet service yet!?

 

Btw we use ASUS DSL-AX82U AX5400 WIFI VDSL/ADSL MODEM ROUTER, all the lights of the modem are on but the internet indicates disconnected. Did absolutely everything whatever the technical support informed but nothing is working.

 

2 REPLIES 2
David_AGL
AGL Community Manager
1 Reply 856 Views

Hi @jacjacp , this does sound like an enormously frustrating experience. Can you let us know what was the conclusion of your last call to support, assuming your internet still wasn't up and running?

KraZeyMike
Switched-on
0 Replies 724 Views

Hi,

 

Any update on this?

I had a similar situation with my own TP Link modem router. Internet light was on but no internet.

After three days of customer service telling me everything was good on their end, I cancelled the AGL NBN and went back to my old provider.

My old provider had me online in less than 10mins! Then they called me to confirm I was back online!

 

It's such a shame because I really did want to use AGL NBN plan but could not get internet access no matter what router settings and after multiple calls and waiting.

 

Also AGL told me I would not be billed for the failed internet connection but my account has a $16 charge left on it for a "disconnected" NBN service.