Gas bill "Make a payment" button not prefilling webform

Superconductor
1 Reply 263 Views

The most recent AGL gas bill "Make a payment" button has introduced a bug that causes the "Make a payment" web form to not prepopulate.

 

Stephen2Aus_0-1647399025879.png

 

 

See below the server response given when clicking the link from email:

$ http "https://analytics.linkre.direct/clickthrough?id=90EEC136F891458B8AC0CED14473B72A&issuer=agl4p&template=AGL0025&url=https://www.agl.com.au/help/payments-billing/make-a-payment?cd_community=AGLTER&cd_currency=AUD&no_reference=70713315789408527727&am_payment=$65.94&CP_billpayCode=208868&cide=edm%7Cbi%7C101"
HTTP/1.1 302 Found
Connection: keep-alive
Content-Length: 89
Content-Type: application/json
Date: Wed, 16 Mar 2022 02:40:40 GMT
Via: 1.1 1ec4518328860e80167b6c9d3bb9fd18.cloudfront.net (CloudFront)
X-Amz-Cf-Id: uSg-ElLrX9XzMGJS3LRQXn9CXvLZTzLsv-qxtLj1uifAGRx2tOGTLA==
X-Amz-Cf-Pop: MEL50-C2
X-Amzn-Trace-Id: Root=1-62314e28-531f170723123186116409b4
X-Cache: Miss from cloudfront
location: https://www.agl.com.au/help/payments-billing/make-a-payment?cd_community=AGLTER
x-amz-apigw-id: PDkmaFcAywMF2GQ=
x-amzn-RequestId: 77d7f300-f0b3-484c-8c02-a3421f352b76

 

The `location` header returns: https://www.agl.com.au/help/payments-billing/make-a-payment?cd_community=AGLTER

 

But has been truncated of important information, and should be returned as: https://www.agl.com.au/help/payments-billing/make-a-payment?cd_community=AGLTER&cd_currency=AUD&no_r...

 

This bad URL leads you to the right webform, but important fields "AGL reference number" and "amount" are not prefilled:

Stephen2Aus_0-1647399259861.png

 

This makes the user experience much worse, and I hope you can resolve this ASAP.

 

 

Feel free to reach out to me for further clarification.

 

8 REPLIES 8
Superconductor
2 Replies 215 Views

Anyone interested in this? It happened still this month, so obviously a problem.

 

It would be a simple fix too, on AGL's server side, for a big UX improvement for I'm sure tons of customers.

 

@David_AGLyou're the only AGL staff's name I know, so tagging you

 

Superconductor
0 Replies 214 Views

@-Nam- @jaydeny maybe?

AGL Community Manager
1 Reply 210 Views

@Stephen2Aus , thanks for taking the time to let us know, I'll make sure this gets actioned.

 

If a post answers your question, please click MARK AS SOLVED!

This helps others in the community find the answers they're looking for.
Switched-on
1 Reply 204 Views

Hi,

 

Same happens with my payment emails for the second months now. Both for electricity and gas accounts.

Superconductor
1 Reply 145 Views

@David_AGLthis is my monthly bump on this, which I'll annoy you with until it's resolved.

 

Hope this nagging is taken with the good humour it's given.

 

This user experience defect isn't insignificant

AGL Community Manager
1 Reply 88 Views

Hi @Stephen2Aus ,

 

Thanks for staying on it, and thanks for your patience! Believe it or not, this has been under active investigation all this time. 

 

The team looking into it have just asked for a copy of one of the the problematic emails, would you mind fowarding one to me?

 

I'll send you a PM with my email address.

If a post answers your question, please click MARK AS SOLVED!

This helps others in the community find the answers they're looking for.
Superconductor
1 Reply 83 Views

No probs @David_AGL 

 

Haven't got a PM from you, but here is the link from the "Make a payment" button:

 

https://analytics.linkre.direct/clickthrough?id=24915CC9702D4BDC85AC93CC18057A31&issuer=agl4p&templa...

 

You can tell your developers that when this URL is contstructed, the problem is the "url" querystring parameter isn't URL encoded. The correct link URL would be like:

 

https://analytics.linkre.direct/clickthrough?id=24915CC9702D4BDC85AC93CC18057A31&issuer=agl4p&templa...

 

^^^ which if you click, you will see it prefills properly.

 

tl/dr: engineers need to URL encode the "url" query string parameter

 

 

 

Superconductor
0 Replies 32 Views

@David_AGLhi, this is my monthly bump on this issue which still occurred on the gas bill received this morning.

 

If you guys need an extra engineer, make me a job offer 🙂