Technical Issues

Having a problem accessing the AGL Energy app or online services? Let us know here!

Having a problem accessing the AGL Energy app or online services? Let us know here!

App does not show current usage. Has trouble connecting to my account details

Switched-on

My AGL app won't show any data for my gas and power.

Click on usage - top left corner has "Connection in progress" Photo of a man next to a light and tv set up in the background.

 

Has been like this for days. Have tried deleting and reinstalling app to fix issue. 

 

Any help would be great,

 

Thanks!

50 REPLIES 50

Semiconductor

This app has been a waste of time. It has never worked and won’t show my account. All I get is some stupid rain drop image.

Switched-on

Hi, i am having the same issue. Quick solution would be awesome

Switched-on

I am having the same issue and have only just started with AGL 

AGL Community Manager

@Keren84 , if you've recently joined AGL you will see this error message when you access the app. Check back in a little while.

If a post answers your question, please click MARK AS SOLVED!

This helps others in the community find the answers they're looking for.

Semiconductor

Hi David_AGL - how long is a “little while”. I have now been waiting weeks and the app is still giving the error message.

AGL Community Manager

@Unhappy1970  So you have been connected for weeks but you are still receiving the "Connection in Progress" error message in the app?

If a post answers your question, please click MARK AS SOLVED!

This helps others in the community find the answers they're looking for.

Switched-on

AGL Energy App is not showing my electricity and solar usage from 02/10/2019.

I have updated the app to the latest version available but still no data displayed.

Switched-on

I’m having the same problem - data is missing since the 3.10. 

Switched-on

Same with mine

Switched-on

My app is not showing daily updates since mid November