Internet

Everything related to your AGL Internet plan

Everything related to your AGL Internet plan

Swapping to AGL NBN - no warning for cutover - it just died at peak time

Semiconductor

Swapping NBN from TPG to AGL. Was told there would be no hassles, AGL would organize it all.
Without warning, mid evening, AFTER the help desks had closed, an email from TPG arrived saying they'd disconnected the line, and the AGL "my account" page says "NBN account being set up".

No prior indication during the sales call there would be downtime.
No emails ahead of time about what day it might happen, how long the line would be down, what else I might need to do.
No help desks open to advice what is going on or when I might get reconnected, or if I have to do anything.

Very poor customer service.


6 REPLIES 6

AGL Community Manager

Thanks for the feedback @Dave-B , sorry you had a bad experience here. I've passed it on to the team.

 

Have you been in touch with customer service about this now?

If a post answers your question, please click MARK AS SOLVED!

This helps others in the community find the answers they're looking for.

Semiconductor

No, things did not get better after contacting customer service.  They went downhill.
Yes, I got told to wait for a text saying things were set up.
And that I would have to do nothing but turn my equipment on and off again.
I asked were they sure, there was nothing else?  It was a TPG modem, and there was nothing I had to do?
They were sure.
Text arrived, I did as I was told, it was not working, rang again.  Was told it was not AGL modem do they could not diagnose.  I asked again, was there nothing I had to do to the TPG-supplied modem?  No, they said, it should just work.
So I ordered the AGL modem.
Hours later I decided to get the diagnostics myself from the logs inside the TPG modem.  Showed TPG modem detected the wires connected from the NBN box, sent packets, but timed out waiting for a response. Rang AGL again. THIS time a nice girl took me seriously, ran tests on the NBN that took minutes, not seconds, said the NBN box was working perfectly.  She said she new the TPG modem, because there were lots of people coming over.  So I had to go to the network settings, take out the TPG-specific configuration (they said "TPG" at the front of the connection string, and where the DNS settings were coming from), and turn on autoconfigure.  Voila - 5 seconds later, all done.

So I had ordered a $96 piece of equipment for nothing.

Simply because the first AGL tech desk operator pushed the 10-second NBN test button, not the 3 minute NBN test button, and couldn't be bothered saying "are you able to go into the TPG modem config that everyone is coming from and click the autoconfig button?".

I'd told the first guy I'd been programming computers since 1975 and we into the admin screens of the TPG modem, so he'd have known I was technically competent enough to find the network config screen - and it's the standard issue every single TPG NBN customer would be having.  So this would surely be almost the single most common issue for ex TPG NBN customers swapping over.

Which says there is either ultra-poor communications inside the change management and help desk, or perhaps a deliberate and dishonest process to get people buying the AGL modems when they are not needed, because the "you will need to disable the TPG configuration and turn everything to autoconfigure" message would be given to every customer.

Tags (1)

Semiconductor

Am having so much trouble myself. Have a Telstra modem that has worked perfectly with another provider (not Telstra) but when I finally did speak to someone from Agl about my drop out issues and poor connection, the response was it’s not an AGL modem so I can’t help you. Which is nonsense. Now I just want my login details for my account to try but can’t get through at all to anyone!! 

Semiconductor

LaraC

Try logging into your modem through the web interface (probably 192.168.x.1 - x could be 0, 1, 5, 10, 20, or 100.  The username will usually be admin, and the password .... well, unless you set it to something, look up the factory default for your machine.  Then go into the advanced settings and set it to "auto" for everything, that helped with me.

Semiconductor

It really is hit and miss.  It's fairly obvious they have not integrated their internet service into their billing, their website, their app - anything.

From looking at the history, they only recently bought what was a good local government co-op from regional NSW, but in trying to scale up to metro, they don't seem to have anything right because they just don't have the telco experience running change management, getting consistent staff training, etc, etc.

Bills arrive in my email, but I can't pay them because the online system hasn't got the bill details .... 

Super Charger

Well articulated Dave, I leapt at AGL mobile & internet due to the pricing & speed promises, which are mostly delivered on albeit more frequent drop outs than Optus & Telstra.

The lack of successful integration via the desktop/phone UI still to this point is surprising. 

The rest of the desktop/phone UI is fantastic, so I'm fine to continue waiting.